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Author
This program was written by J.R. Toelken. It uses licensed code from other authors to 
actually read Exif data.  My programming provides the user interface and data 
formatting, analysis features,  plus the DDE interface.

Introduction

JPEGMetaDataReader is written with the Delphi programming language. It is 
designed to be a stand alone program that can be used by itself to view the Exif and 
other metadata contained in .JPG, .TIF and .PSD files. Its primary purpose is to report 
this information via the DDE interface to other programs such as Access database 
programs. If you run the program via the user interface, you can set various 
configuration options that affect how data is reported via DDE. Just double click on 
the program to use the normal user interface. (Note, it may open minimized, since 
that is the default behavior.) In addition to reporting Exif data and makers notes, this 
program can also report CRC hash and/or MD5 hash via the exact same DDE 
interface. 

The earlier versions of this program, 1.0.0.x, were written with Delphi 7 and used 
Exif reading code called dExif. The author of dExif has abandoned maintaining that 
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code. Version, 2.0.0.x is written in Delphi XE2 and uses the CCR-Exif package by 
Chris Rolliston. It adds the ability to display many makers notes and user tags 
generated by programs such as Photoshop Elements. It also adds many configuration 
options and this help file. The default formatting of Exif data and all DDE methods of 
receiving that data should be exactly compatible with the older version of the 
program and require no changes for an Access program. The default formatting is 
based on dExif which presented the Exif data in tag number order. Version 3.0.0.x is 
written in Delphi 10.3 and includes ImageEn to view images and display Exif data, 
plus the prior Exif and makers notes from CCR-Exif. It also adds many research and 
comparison features to try to diagnose previously unidentified makers notes tags.

What is EXIF data?
Exif data is information stored inside each .JPG or .TIF file created by a digital 
camera. Photoshop may retain much of the data when it converts an image file to its 
own style of file, .PSD. This program can display the Exif data, if any, from .JPG, 
.TIF, and .PSD files. A camera typically stores useful things like the make and model 
of the camera, the shutter speed, aperture, focal length, photo resolution, ISO speed, 
and whether the flash was used. It also records the date and time of the photo, based 
on the camera's internal clock. There is a wide variety of other information stored by 
cameras which may be of value in figuring out what camera settings yield the best 
photos.  Exif is also used as a generic term for a variety of other data including XMP, 
IPTC, and Makers Notes. If available these types of data are also displayed.

NOTE: If a photo has been edited, the editing software often loses some or all of the 
EXIF data. Photoshop Elements in particular seems to loose all Makers Notes when it 
edits a file, but doesn’t lose the normal Exif data. You should make backup files 
before editing them. Scanned images typically have no EXIF data so this program 
won’t be very useful.

What is DDE?
DDE is a protocol for direct communication between programs. The program sending 
DDE commands is called the DDE Client and the program receiving and obeying 
DDE commands is called the DDE Server. For example: An Access program would 
be called the DDE Client and this program would be called the DDE Server because 
it serves up data to the Access program.

Configuring to control JPEGMetaDataReader via DDE
Your DDE Client program such as Access must be capable of configuring the 
required details to initiate and use a DDE link to talk back and forth between the two 
programs. You will need to specify this information:
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DDEname =     JPEGMetaDataReader  (the name of this program)

DDEtopic =     DdeServerItem1
Sample Access code to open DDE connection:
lDDEChannel = DDEInitiate(“JpegMetaDataReader”, “DdeServerItem1”)   ' 
Establish link and store handle in lDDEChannel, a long integer.
Establish a link once and then use the link to request as many file inspections as 
needed.

Receiving Exif data via DDE
Once your program has established a DDE link with JPEGMetaDataReader, it then 
needs to communicate what file it would like to view the Exif data and it needs to 
receive the Exif data back from JPEGMetaDataReader.  These steps can be repeated 
as often as needed while the DDE connection is open.  Step 1 is to tell 
JPEGMetaDataReader what file to read using the DDE command to read a file: 
{ReadEXIF}|%1. This command and all DDE commands are case sensitive. They 
should appear exactly as written. 
Your program must replace the %1 with the file name, similar to this:

Function jrOpenDDEfile_JPG(inChannel As Long, inFile As String) As Boolean
On Error GoTo ErrjrOpenDDEfile_JPG
Dim sFile As String
Dim sOpenMsg As String
sOpenMsg = "{ReadEXIF}|%1"
    If inChannel = 0 Then
        MsgBox "No DDE Server was able to be launched.", vbExclamation, "Error"
        jrOpenDDEfile_JPG = False
    Else
    '    Delphi auto closes prior file before reading next file
        sFile = inFile
        sOpenMsg = StringReplace(sOpenMsg, "%1", sFile)

        DDEExecute inChannel, sOpenMsg
        jrOpenDDEfile_JPG = True
    End If
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ExitjrOpenDDEfile_JPG:
Exit Function
ErrjrOpenDDEfile_JPG:
If Err = 285 Then
    If Not bHide285ErrorMsg Then
        If MsgBox(Err & " The DDE Server program reports it was unable to view 
the requested file." & vbcrlf & vbcrlf & inFile & _
            vbcrlf & "The server may have been closed improperly." & vbcrlf & 
vbcrlf & _
            "The DDE Server may not understand the [DDE Open Message] as 
configured." & vbcrlf & vbcrlf & _
            "The DDE Server may be incorrect, so hiding this message may be the 
correct solution." & _
            vbcrlf & vbcrlf & "Hide this message in the future?", _
            vbYesNo + vbInformation, "jrOpenDDEfile_JPG Error") = vbYes Then
            bHide285ErrorMsg = True
        End If
    End If
ElseIf 7952 Then
    MsgBox "The DDE Server was manually closed without this program's 
knowledge." & vbcrlf & vbcrlf & _
        "Close this form and re-open it to allow it to launch the DDE Server again" 
,_
        vbInformation, "jrOpenDDEfile_JPG Error"
    lDDEChannelJPG = -1    'block continued use of DDE
Else
    MsgBox "Error # " & Str(Err.Number) & ". " & Err.Description, , 
"jrOpenDDEfile_JPG Error"
End If
jrOpenDDEfile_JPG = False
Resume ExitjrOpenDDEfile_JPG
End Function

Step 2 is to receive and process the Exif data from JPEGMetaDataReader. This is a 
sample function to receive, processing is up to you:
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Function jrReceiveDDEdata(inChannel As Long) As Variant
On Error GoTo ErrjrReceiveDDEdata
Dim vDDEdata As Variant
vDDEdata = DDERequest(inChannel, "DdeServerItem1")
If jrEmpty(vDDEdata) Then
    jrReceiveDDEdata = "Not an EXIF file" 
Else
    jrReceiveDDEdata = vDDEdata
End If

ExitjrReceiveDDEdata:
Exit Function

ErrjrReceiveDDEdata:
MsgBox "Error # " & Str(Err.Number) & ". " & Err.Description, , 
"jrReceiveDDEdata Error"
Resume ExitjrReceiveDDEdata
End Function

Be sure to return the value of this function to a memo field on a form, or a string 
variable. It will return much more than 255 characters for most files, so a text field 
will not work. This program lets you choose many options for how the data is 
formatted before being returned. The user interface of the program will let you see 
what your Access program should be receiving. In my Access program I return the 
Exif values into a global string variable and then parse that variable to obtain the few 
actual Exif tags that I desire. That isn’t technically necessary anymore since the new 
version of JPEGMetaDataReader lets the user interface specify the exact tags that you 
wish to use in your Access program by setting favorites.

Telling this program to ignore a file
If your DDE Client program is able to detect that a file won’t have Exif data to 
display, it can decide not to send the file name to JPEGMetaDataReader. This has a 
downside though since the program will still display the Exif data for the preceding 
file and that might be confusing. If this situation exists for you, you can send an 
alternate DDE command.  Instead of sending {ReadEXIF}|%1, send 
{NOEXIF}|%1. This alternate command tells this program to clear all of its displays 
and substitute just a message that shows the file name and the fact that no Exif is 
available.
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DDE Close Message: 

When you finish processing files and receiving Exif data into your Access program, 
you must close the DDE connection.
There is only one command to close the DDE connection to this program: {Close}
That command should appear by itself and must include the curly braces around it. In 
fact all of the DDE commands are surrounded by curly braces { }. 
This command and all DDE commands are case sensitive. They should appear 
exactly as written. 
Sample Access code:

DDEExecute lDDEChannel, "{Close}"  ‘use lDDEChannel handle to identify 
what DDE link is being closed.
DDETerminate inChannel ‘terminate the DDE handle

Customizing the program
In addition to setting the configuration options via the Configuration menu you 

can also customize the caption displayed by this program. This requires manually editing 
the .INI file with a file name that matches the program name.

Open the .INI file with a simple editor such as Notepad.exe. Double clicking on the .INI 
file usually launches Notepad.

Find the [System] section of the file.
Insert a row below the [System] tag such as this:

caption=Ver 1.5.0 JPEG Reader

Now the program caption will say “Ver 1.5.0 JPEG Reader” instead of the default caption 
“Delphi EXIF Jpeg Viewer”. 

Detailed Program Operations
The user interface of the program looks like this:
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v

Special Keys
Note: The left and right panels are memo fields. The following special keys are available:

Use Ctrl + A to hi-lite an entire panel for copying to the clipboard. Both panels can be 
edited, if desired. The desired panel must have focus.
Use Ctrl + Plus to increase the font size in both panels. Focus is not required on a 
particular memo field. The selected font size is remembered when you close the program 
and restored when you open the program again.
Use Ctrl + Minus to decrease the font size in both panels. Focus is not required on a 
particular memo field.
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File Menu

Open
This option provides a common file dialog to select your image file. It has several 
filtering options to limit the display of image files and speed your selection. .JPG, 
.TIF, and .PSD files can be read. All files will display a thumbnail if Show Image is 
checked. If you have a program like my Photorenamer.exe which uses the DDE 
interface to tell this program the name of the next file to inspect, it will be faster and 
easier to compare a large set of files. This menu option is good for smaller inspection 
tasks.

Reload
This option reloads the currently selected file. This is very useful after changing your 
desired configuration of the Exif display in the right panel or your favorites in the left 
panel.

Save As
This option saves the file with a new file name and shrinks the file drastically to allow 
fast upload to meta data websites. The metadata is not harmed by this shrinking. The 
file name that is offered removes any spaces since some websites don’t play well with 
long file names.

Exit
This option exits the program and saves all configuration options in the .INI file. If 
the program began without a .INI file, then a new .INI is created.
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Edit Menu

The Edit Menu has only one option, Find. The hot key Ctrl+F also activates the find 
feature.
The Find feature searches whichever panel currently has focus.  It looks like this:

Just type what you desire to find inside the Find what field and click Find Next. If 
you wish to search the other panel, just click in the desired panel, then click Find 
Next again.

Configuration Menu

Select DDE Data Source
This option lets you choose which panel will supply the Exif information over the 
DDE interface. 
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CCR-Exif Left Panel
If you choose the left panel you must use the Configure Favorite Tags for Left 
Panel option to select what information is delivered via DDE. 

CCR-Exif Right Panel
If you choose the right panel, you can select how the Exif data is presented via the 
Right Panel viewing options menu. The default selection is Right Panel.

ExifTools (slower)
This option will report the results of running ExifTools.exe. It will automatically 
switch to CCR-Exif Right Panel if ExifTools.exe is not available. ExifTools 
presents its data in its own format. Any program receiving this data via the DDE 
interface will need a custom function for parsing the data, different from the 
function for parsing CCR-Exif data. Because ExifTools.exe is a command line 
utility, this option will be much slower than using the internal CCR-Exif 
information.

Exiv2 (slower)
This option will report the results of running Exiv2.exe. It will automatically 
switch to CCR-Exif Right Panel if Exiv2.exe is not available. Exiv2 presents its 
data in its own format. Any program receiving this data via the DDE interface 
will need a custom function for parsing the data, different from the function for 
parsing CCR-Exif data. Because Exiv2.exe is a command line utility, this option 
will be much slower than using the internal CCR-Exif information.

Display Option
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This option lets you choose whether the program opens minimized or maximized. 
When the program is used to provide data via DDE there is no need for it to be 
visible, so the default choice is to open minimized. Opening maximized is 
primarily of value when using the user interface to select files or configure 
options. It is also valuable when using the user interface to research and modify 
makers notes translations.

Configure Favorite Tags for Left Panel

If you choose the left panel as the DDE data source, you should configure 
favorites. Favorites are your selection of Exif tags and makers notes tags from the 
right panel. You can insert them in any order. They will be presented in the order 
you have selected. To begin configuring favorites you must have a current file 
displayed.

There are two steps to configuration. First click Create/Edit Tags to Display. This 
will disable several conflicting menu options. It changes the right panel to read-
only to prevent accidental changes. You can then use the clipboard to copy 
individual Exif tags from the right panel to the left panel. Copy the entire tag and 
its value. There is no need to delete the current value after the equal sign. The 
program will do it for you when you save the tag configuration. It will also trim 
any leading spaces from the tag. You can copy separator lines from the right panel 
to help group your tags into visually easy groups. --- and === are common 
separator lines.

The second step is to click the Save Tag Configuration option. It was enabled 
when you began Create/Edit. The save option stores the list of favorites in the .INI 
file after trimming off the current values after the equal sign. It restores the 
disabled options and changes the right panel back to being editable.

NOTE: The program will only report favorite tags in the left panel that exactly 
match tags in the right panel. If you turn off Sort Makers Notes the tags in the 
right panel will include the numeric tag identifier. If the favorites tags don’t have 
those identifiers, they will no longer appear as favorites. For example:

[$0001] Image quality = High
[$0002] Firmware version = {00010500}
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NOTE: Favorites are not displayed if they aren't found. This lets you set favorites 
for tags with different names with different camera makers that are synonymous.

Once you have completed configuration, the File > Reload option will make it 
easy to test the results by reloading the current file.

Right Panel viewing options

This menu option offers multiple choices to determine what information is 
presented in the right panel and how it is formatted. Note the separator bars in the 
submenu. The top two groups delineated by those separators can only select a 
single option at a time since they are mutually exclusive.

Show dExif format
This is the default setting. This option will display the Exif information in the 
same order and almost entirely in the same format as the old dExif code did in 
earlier versions of this program. dExif reported the Exif tags in the order in which 
they were stored, so this will be the best option when comparing to the reporting 
from ExifTools.exe or Exiv2.exe. Minor formatting improvements were made to 
some values so that the client Access program doesn’t need to do that anymore. 
These changes did not harm my legacy Access code. As an example, dExif 
presented some values as fractions whereas this program presents the calculated 
result of the fraction. For example, dExif presents 

“Exposure Bias Value = -66/100” and this program presents 
“Exposure Bias Value = -0.66 EV”. 

In other cases such as resolution values, this program presents the same fractional 
values as dExif, but also presents a friendlier format like this:

Focal Plane XResolution = 3264000/291
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Focal Plane YResolution = 2448000/219
Focal plane resolution = 11216 x 11178

This program also calculates the MegaPixels value whereas dExif did not.

dExif presented the ISO speed with several tags: “ISOSpeed Ratings”, “ISO:” and 
“ISO Speed”. This program standardizes with “ISO Speed”.

Show CCR-Exif format
CCR-Exif normally presents its data according to how Exif data is organized 
inside an image file with useful group headings. 

Show only Makers Notes
This option is mutually exclusive with the Do Not Show Makers Notes option.

This option might be useful while trying to customize the program to correctly 
translate Makers Notes for your camera. See the Makers Notes section for further 
details.

Show Logical Groups
This option displays the Exif tags in groups that seemed logical and useful to me, 
to make it easier to find the information that is helpful to photographers.

Show Photoshop User Tags
Photoshop Elements (PSE) allows users to edit a large number of Exif and IPTC 
tags. (IPTC tags are additional tags within the Exif data storage specification.) In 
PSE8, select File > File Info. PSE8 presents a multiple tab dialog. This option 
shows any tags entered on the Description and IPTC tabs. Note that some tags are 
duplicated among several tabs, so it may show information entered on other tabs.  
This is the default setting. This option must be selected for these tags to be 
displayed. Note also that PSE does not use some Exif tags in the standard fashion 
which is why there are tags labeled IPTC tags which aren’t shown via the next 
option. This option conforms to how PSE does things.

Show IPTC User Tags
The author of CCR-Exif provides a sample program called IPTC-Editor. It 
displays and edits a variety of IPTC tags, many of which are not represented 
within Photoshop Elements. In the event that you have software which can edit 
these additional tags, this option will show them. This option must be selected for 
these tags to be displayed.

Show Empty Tags
The default behavior of the program is to hide any Exif tag which was not stored 
by the camera. That removes considerable clutter since there are many obscure 
Exif tags. 
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The program automatically tries to find a substitute value for some missing 
values. For example, some cameras record the “Aperture Value” instead of 
“FNumber” and the program performs the same substitution. Some cameras 
record both values.

With values that the program automatically substitutes, it displays them as empty 
when “Show Empty Tags” is turned on.

This feature only controls the display of empty EXIF tags, not Makers Notes tags. 
Makers Notes always show only the tags that are actually found.

Do NOT Show Makers Notes
This option is mutually exclusive with the Show Only Makers Notes option.

 This option blocks the program from most processing of Makers Notes. It turns 
out that Makers Notes can be flaky in some .JPG files. This option will help avoid 
processing errors for such bizarre files. This is the default setting. Note that the 
program will automatically turn off processing Makers Notes for individual files 
if it realizes it can’t process them. See Exif Notes. The program has several 
reporting options:
1. Report the actual Makers Notes.
2. Report “Makers Notes not shown”, because this option is checked.
3. Unable to read Makers Notes values
4. Maker Note = Unrecognized format
5. No MakerNote found. Count of Tags = 0

Include CRC Hash (slow)
This option calculates a CRC hash for the selected file. The hash is displayed at 
the top of each panel, just below the file name, size, and date. This option will 
slow processing if you are performing a mass review of files via the DDE 
interface and another program such as Access. This is off by default.

Include MD5 Hash (slowest)
This option calculates a MD5 hash for the selected file. The hash is displayed at 
the top of each panel, just below the file name, size, and date. This option will 
slow processing significantly if you are performing a mass review of files via the 
DDE interface and another program such as Access. The MD5 hash is a more 
secure hash than the CRC so it takes longer to calculate. This is off by default.
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Show ONLY Hash
This option turns off all Exif and Makers Notes processing. If all you need to 
calculate is one of the hash values, it should speed the processing. This is off by 
default.

Use ImageEn for EXIF – no Makers Notes
ImageEn can read a few more Exif values but does not currently read Makers 
Notes.

Sort Makers Notes
Sorting Makers Notes is the default option since it helps group options logically if 
you have named makers notes tags in a logical fashion. This option lets you 
choose not to sort. If the Makers Notes are not sorted, they are presented with 
their internal tag numbers, in tag number order. This will make it easy to compare 
to the raw Exif data (or data from ExifTools.exe or Exiv2.exe) and try to diagnose 
how to improve the translation of Makers Notes. See the Makers Notes section for 
further details.

Save As Full File Name
The File > Save As option normally shortens the file name and eliminates spaces 
in the file name. This option maintains the full original long file name.

Extras Menu

There is a hidden feature in the program’s .INI file which controls whether the 
Extras Menu is visible. The Extras Menu presents options which may help you 
diagnose details of the Makers Notes or extract additional information from a file. 
The primary purpose is to help figure out better translations for the Makers Notes.
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If you wish to use the Extras Menu, you will need to modify the program’s .INI 
file (not the Makers Notes.INI). Open the .INI with Notepad and look for the 
[System] section. Insert a new tag identical to this:
ShowExtras=1

The default behavior of the program is to not have this .INI tag and not display 
the Extras Menu.

Show CCR Raw Exif with Favorites in Right Panel
This option will display the raw (un-translated) Exif values in the left panel. 
Makers Notes will be presented in the order of the numeric tag, so you should turn 
off sorting Makers Notes via the Configuration Menu so that the right panel also 
presents the data with the numeric tag, in the same order. This may help compare 
the details and perhaps compare the details to information found on the web.  
NOTE: If favorites are displayed in the left panel, they will automatically be 
moved to the right panel. This means you can select favorites for the Exif tags or 
Makers Notes that you wish to compare and have them automatically switch to 
the right panel for easy comparison. You will need to use File > Reload to activate 
this feature with your desired file.

Show CCR Raw Exif with Full Exif in Right Panel
This option will display the raw (un-translated) Exif values in the left panel and 
the full Exif data in the right panel. Makers Notes will be presented in the order of 
the numeric tag, so you should turn off sorting Makers Notes via the 
Configuration Menu so that the right panel also presents the data with the numeric 
tag, in the same order. This may help compare the details and perhaps compare 
the details to information found on the web.  You will need to use File > Reload
to activate this feature with your desired file.

Use ExifTool
https://exiftool.org/

ExifTool.exe by Phil Harvey is a command line utility that understands some 
different Makers Notes and Exif tags than this program. This option will ask 
ExifTool.exe to report on the currently displayed file and load the result into the 
left panel. You can configure the program to present the results of this option over 
the DDE interface.

The default display of ExifTool.exe is to show tags in numerical order, so you 
should turn off sorting Makers Notes via the Configuration Menu so that the right 
panel also presents the data with the numeric tag, in the same order. Also you 

https://exiftool.org/
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should select the dExif style displays of Exif tags. This may help compare the 
details and perhaps compare the details to information found on the web.  

NOTE: If favorites are displayed in the left panel, they will automatically be 
moved to the right panel. This means you can select favorites for the Exif tags or 
Makers Notes that you wish to compare and have them automatically switch to 
the right panel for easy comparison.

ExifTool.exe is a command line utility which means that it will be somewhat slow 
and you will see a black command window appear briefly when it executes. In 
fact this program creates a batch file called “JRExifTool.Bat” which contains the 
command line, and then executes this batch file. The batch file creates a text file 
called “jrExifTool.txt” which is loaded into the left panel.

ExifTool.exe has many command line switches to control its operation. The 
default command line switches are “-a -u -t -g1 –H”. This can be changed by 
reading the “ExifTool help.txt” to learn about other switches, then modifying this 
program’s .INI file. Look for the following section of the .INI file and modify it 
as needed:

[ExifTool]
CommandLine=-a -u -t -g1 –H

Version 3.x of this program is provided with a copy of ExifTools.exe, version 
11.9.2.0

Use Exiv2
http://www.exiv2.org/index.html

Exiv2.exe by Andreas Huggel is a command line utility that understands some 
different Makers Notes and Exif tags than this program. This option will ask 
Exiv2.exe to report on the currently displayed file and load the result into the left 
panel. You can configure the program to present the results of this option over the 
DDE interface. This option was last tested in version 2.x of this program.

The default display of Exiv2.exe is to show tags in numerical order, so you should 
turn off sorting Makers Notes via the Configuration Menu so that the right panel 
also presents the data with the numeric tag, in the same order. Also you should 
select the dExif style displays of Exif tags. This may help compare the details and 
perhaps compare the details to information found on the web.  

NOTE: If favorites are displayed in the left panel, they will automatically be 
moved to the right panel. This means you can select favorites for the Exif tags or 
Makers Notes that you wish to compare and have them automatically switch to 
the right panel for easy comparison.

http://www.exiv2.org/index.html
http://www.exiv2.org/index.html
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Exiv2.exe is a command line utility which means that it will be somewhat slow 
and you will see a black command window appear briefly when it executes. In 
fact this program creates a batch file called “JRExif2.Bat” which contains the 
command line, and then executes this batch file. The batch file creates a text file 
called “jrExiv2.txt” which is loaded into the left panel.

Exiv2.exe has many command line switches to control its operation. The default 
command line switches are “-PEIXlxtvgy”. This can be changed by reading the 
“exiv2-man.html” to learn about other switches, then modifying this program’s 
.INI file. Look for the following section of the .INI file and modify it as needed:

[Exiv2]
CommandLine=-PEIXlxtvgy

This program is provided with a copy of Exiv2.exe, version 0.21.1. Note that 
Exiv2.exe also requires libexpat.dll to be in the same folder. It is also provided 
with this program.

Display incoming DDE command
This includes the DDE command in the right panel display. It is for error analysis 
if your DDE client program is not receiving the desired data.

Popup Comparison Form
This option pops up a form that is designed to help compare Exif and makers 
notes between two files. It shows two panels. Paste the right panel data from the 
main program into one panel and after changing files, paste the right panel data 
into the other panel of the popup. There are a variety of features to assist in the 
comparing the data from the two files. Or you can paste data from one image file 
into a panel and paste data for that file from one of the websites to compare.

Test Hexadecimal Translation to Characters
The contents of many unknown makers notes are reported as strings of 
hexadecimal characters. This option lets you test to see what ASCII characters 
they translate into.

Test Hexadecimal Translation to Numbers
The contents of many unknown makers notes are reported as strings of 
hexadecimal characters. This option lets you test to see what ASCII numbers they 
translate into.
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Launch Metadata Website
This option launches a website that allows you to drag and drop a file to analyze 
and display its metadata:
https://www.apotelyt.com/photo-tools/exif-data-viewer

This website requires a file name with no spaces and a full sized image file will 
take a long time to upload. Be sure to use File > Save As to shrink the file and 
convert the file name so that it has no spaces and works with this website.

This website uses the latest metadata translations from Phil Harvey. Most of the 
Exif tag names used by this program have been matched to this website to make it 
easier to compare them. When customizing the makers notes .INI file I also try to 
name the makers notes with the same tag name as used on this website.

It is valuable to use this website to try to identify additional maker notes tags and 
add them to your translations when customizing the makers notes .INI file.

Launch Metadata Website
This option launches a website that allows you to drag and drop a file to analyze 
and display its metadata:

https://www.metadata2go.com/

This website does not require a file name with no spaces. But a full sized image 
file will take a long time to upload. Be sure to use File > Save As to shrink the file 
for easy uploading to this website.

It is valuable to use this website to try to identify additional maker notes tags and 
add them to your translations when customizing the makers notes .INI file.

The data provided by this website can be copied to the clipboard. It must be 
pasted into the left panel of the popup form since that is the only panel that can 
reformat the data from two lines to a single line for accurate comparison to data 
from the other website or from this program.

Research Tag in Selected Files
If you observe that the value of an unknown makers notes tag is changing when 
you change a camera setting, this option may help to see if that value change is 
meaningful and can be interpreted. Use the main panels of this program to copy a 
tag name to the clipboard, then paste it in to the input box for this feature. It will 
prompt for a second optional tag name too. It then prompts you to select the files 
to research for these values. The research process can take awhile so it presents a 
status display below the thumbnail image. (I recommend researching all of your 
samples files to gain an understanding of how the subject tag is being used.) It 
presents the results on the clipboard in a columnar format containing the one or 

https://www.metadata2go.com/
https://www.apotelyt.com/photo-tools/exif-data-viewer
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two values you are researching plus the file name of each image file. You can 
paste these values into any text display like Notepad.exe or into the popup form
provided by this program. Sometimes it is very frustrating because the unknown 
values change regularly but not in a way that I could interpret. Sometimes I was 
able to confirm exactly what the unknown tag was reporting.

Exif Notes
The Exif specification is not fully supported by all cameras. The following notes 
will explain some anomalies:

 Not all cameras record the “Date time” value. Unless the Show Empty Tags
option is turned on, the program automatically inserts the “Date Time original” if 
the “Date time” is missing.

 Some cameras record the “Shutter Speed Value” instead of the “Exposure Time”. 
Unless the Show Empty Tags option is turned on, the program automatically 
inserts the “Shutter Speed Value” and calls it “Exposure Time” to provide a 
standard output form.

 Some cameras record the “Aperture Value” instead of “FNumber”. Unless the 
Show Empty Tags option is turned on, the program automatically inserts the 
“Aperture Value” and calls it “FNumber” to provide a standard output form.

 Apparently cameras do not record the “Max Aperture Value” very well. I’ve seen 
situations where the reported maximum aperture was less than the actual aperture 
used! (This was true for multiple different programs reading the same Exif data.) 
ImageEn appears to get this right, so it is always used to read this value.

 Not all cameras record the “Focal Length in 35mm Film” value. If enough other 
information is recorded, the program will calculate the correct value and put 
“EST” after it to alert you that it was calculated, like this: “Focal Length in 35mm 
Film = 36.48 mm EST”.

 Exif can store GPS information, if the camera is GPS equipped. This program 
added new formats of GPS data to be compatible with Bing and Google Maps. 

 Exif tags may be lost when editing an image with some programs.
 Exif tags may be changed by image editing programs.
 Makers Notes data may be lost when editing an image. Apparently the Exif 

specification is not very precise, making it difficult to preserve some Makers 
Notes. As an example, Photoshop Elements 8 (PSE8) removes the Makers Notes 
if you use its feature to enter your own user tags or if you edit a photo with PSE. 
This reinforces the need to keep a backup of photos that you edit and to analyze 
your camera settings on an unedited copy of the image file.

 When emailing images, Windows often offers to shrink the image file. Exif data 
seemed to survive the shrinking but User Tags from PSE were lost as were 
Makers Notes.

 There are several types of Makers Notes recorded by Nikon cameras. Some 
cameras that use NikonType3 Makers Notes do not record the ISO in the regular 
Exif tag. This program attempts to find the information in the raw Exif data tag 
for Makers Notes, $0002, unless the Show Empty Tags option is turned on. 
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Unfortunately some don’t record it in a way known to this program. The program 
also tries to extract the ISO from raw makers notes in NikonType2 format, if 
possible.

 This program is capable of reading Canon and Nikon makers notes but I have few 
.jpg files to test and no cameras. I have multiple Panasonic cameras and a huge 
number of test images so the makers notes for Panasonic cameras are the best 
developed.

Makers Notes
The normal Exif tags are specified by an industry wide specification. But camera 
manufacturers constantly improve their cameras and need to store additional 
information about the settings of the camera. The Exif specification provides 
space for them to do this by recording any data they want, in any format they 
want, within the Makers Notes. Since the content and format of the Makers Notes 
is proprietary (and may be encrypted!) and may change from one camera to 
another, it is difficult for a program to read these values and translate them into 
appropriate English. At this writing CCR-Exif provides a mechanism for reading 
and translating many tags for Nikon, Canon, and Panasonic cameras. My 
implementation of CCR-Exif is designed to let users customize the program if 
they discover appropriate translations for Makers Notes tags for their own 
cameras, assuming they are Nikon, Canon, or Panasonic. Only a skilled 
programmer, with access to the source code, can add new makes. But it is easy to 
customize how the program translates Makers Notes for particular models via the 
MakerNotes.INI file.

NOTE: Makers Notes can be flaky. See the menu option Configuration >  Right 
Panel Viewing Options > Do NOT Show Makers Notes.

MakerNote .INI file
CCR-Exif stores its known Makers Notes translations in the file MakerNotes.INI. 
This program will automatically use that .INI file to translate known and available 
tags. However, it also allows you to create your own .INI file for specific 
cameras. 

If the standard .INI file is used, the program reports like this:
=============== Makers Notes ==================
Maker Note = Canon
INI File used, Standard:  = MakerNotes.INI
Count of items = 116

Alternately you can copy the standard .INI file to a file named with the exact 
Make and Model that is reported from the Exif data in the right panel. For 
example: Panasonic DMC-G1.INI. If the program finds a .INI file that exactly 
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matches this naming convention then it will be used. The program then reports 
like this:
=============== Makers Notes ==================
Maker Note = Panasonic
INI File used, Custom:  = Panasonic DMC-G1.INI
Count of items = 84

Notes about Makers Notes:
 It is not necessary to retain all information about other cameras that is 

stored in the custom .INI file. For example, you may remove all Canon 
and Panasonic information when customizing the translations for your 
Nikon. 

 Many Makers Notes tags are unknown and may be very long. These may 
be truncated in the display to save space and readability.

 If no Makers Notes are found, the program reports like this: “No Makers 
Notes found = Canon”.

Customizing Makers Notes translations
It is common for camera makers to add new features that are saved with new 
codes. For example: The Panasonic translations in this program include only 4 
options for “Focus mode” but my DMC-G1 saves a fifth option. The number and 
variety of makers notes exploded with the advent of the GH3 and later the G9 
model camera. Below you will see how I improved that situation and updated the 
Panasonic DMC-G1.INI file.

There are several ways of identifying improvements to the MakerNotes.INI file. 
For starters be sure to Google your camera and “makers notes” to see if someone 
else has done the work for you. And be sure to use the websites that this program 
can launch for you.

Next you can make sample photos with your own camera and carefully record the 
settings you used so you can compare them to how the program reports the 
settings.  (I use my program, Photorenamer.exe, to rename each file with 
information that describes the specific settings being tested.) Be sure to read the 
owner’s manual to learn about setting options.  

When reviewing Makers Notes, you will find it best to use the favorites feature to 
select the Makers Notes you wish to review. Configure > Configure Favorite Tags 
for Left Panel. That will make it easy to see them as you process different picture 
files to see what the camera recorded. You might also find it helpful to select 
Configure > Right Panel viewing options > Show Only Makers Notes. The popup 
form is particularly useful for comparing makers notes tags between two image 
files or comparing the tags from this program to those from the available 
websites.
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Obtain the actual values of the codes stored in the Makers Notes by using Extras 
> Show CCR Raw Exif. Then update the .INI file if you learn anything new.

It is often useful to use the File > Reload option to easily inspect the same file 
with another configuration setting.

Another method is to use the Extras Menu. It provides a method of loading Exif 
and Makers Notes from two other programs that appear to be quite 
comprehensive. Comparing their results with the results of this program may 
allow you to update some of the translations in the MakersNotes.INI file for this 
program. NOTE: These additional programs may NOT have additional 
information at times, and may be just plain wrong for your camera. Testing your 
own camera is the best bet. Also note that you should obtain the latest versions of 
these programs as they are updated to accommodate new cameras.

Perhaps the easiest method is to use the Extras Menu. It provides a method of 
launching two different websites that may report useful metadata. Comparing
their results with the results of this program may allow you to update some of the 
translations in the MakersNotes.INI file for this program.

MakerNotes.INI editing example
The original MakerNotes.INI contains the following two tags:

[TPanasonicMakerNote.$0007]  do not change this
TagDescription=Focus mode  Do not change “TagDescription=”. 

“Focus mode” is the description displayed 
as a tag by this program.

1=Auto
2=Manual  These are the translation values
3=Auto, focus button
4=Auto, continuous

[TPanasonicMakerNote.$000F]  do not change this
TagDescription=Spot mode  Do not change “TagDescription=”

In this example, there are 4 translations for Focus mode and no translations for 
Spot mode. After testing my camera I made the following changes:

[TPanasonicMakerNote.$0007]
TagDescription=Focus mode
1=Auto Focus Single
2=Manual Focus
3=Auto, focus button  This value may be correct for older 

cameras or perhaps a feature I haven’t 
found yet.

4=Auto, continuous  This value may be correct for older 
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cameras or perhaps a feature I haven’t 
found yet.

5=Auto Focus Continuous  New value (5 was the value in CCR 
Raw Exif)

[TPanasonicMakerNote.$000F]
TagDescription=Autofocus mode  “Autofocus mode” is a better 

description than “Spot mode”
16,0=1 Area Focus  “16,0” was found in CCR Raw Exif
32,0=23 Area Focus  “23 Area” is from the owner’s manual
64,0=Face Detect Focus
;it only records Face Detect if it sees a face.  A semi-colon in front of a line makes it 

a comment that is ignored by the program. 
Use this to document details that might 
help you understand the values you have 
translated.

MakerNotes.INI Adding new translation:
 CCR reported the following information for Canon DSLRs:

   [$0095] Unknown ($0095)Unknown = EF135mm f/2L USM

ExifTools:
0x0095 Lens Model EF135mm f/2L USM

Exiv2:
0x0095 Canon        LensModel                      Ascii      EF135mm f/2L USM

A search of the INI file found no Canon sections for the 0095 tag. Based on this, I added 
a new section to the Canon portion of MakerNotes.INI that looks like this:

;Added by JR Toelken Comment to explain and identify my 
change

[TCanonMakerNote.$0095] New section name to link to the 0095 tag
TagDescription=Lens type New description. I chose the same 

description used for Nikon and Panasonic 
to provide a consistent response via DDE

Now CCR reports:
   [$0095] Lens type = EF135mm f/2L USM
Or, if Configuration > Sort Makers Notes is turned on, it looks like this:

Lens type = EF135mm f/2L USM
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Popup Comparison Form
This popup form is opened via the Extras menu on the main program.  It 
automatically formats the two data panels side by side if on a landscape mode 
monitor or up/down if on a portrait mode monitor. When data is pasted into a 
panel from the right panel in the main program or from a website, you can use the 
features of this form to compare data from two data sources or from two files. 
Ctrl+F also launches a Find dialog for this panel that operates the same as the 
Find dialog in the main program.

Restore Left/Top Panel

Restore Right/Bottom Panel
Many of the analysis options on this form remove data lines that are just clutter so 
you can see the important data. This option restores the original data that was 
pasted into this panel prior to executing the option. It is a single level undo.
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Clear Left/Top Panel

Clear Right/Bottom Panel
Before starting a new analysis, you may wish to just clear all data from a panel.

Go To Top of Left/Top Panel

Go To Top of Right/Bottom Panel

There may be over 300 lines of data containing Exif and makers notes for a single 
file. This is one way to jump to the top of a panel. Ctrl+Home also works.

Clear Left/Top Panel Hi-Lites

Clear Right/Bottom Panel Hi-Lites

These options clear all hi-lites so you can start again.
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Select Line Numbers in Right/Bottom Panel to match Left/Top Panel

Select Line Numbers in Left/Top Panel to match Right/Bottom Panel
If you click in the gutter of one panel to hi-lite rows, you can instantly hi-lite the 
matching line numbers in the other panel. This is most useful if you have use the 
Line Up button.

Convert Left Panel with Two Line Data:
The data in the website available from Extras > Launch Metadata Website pastes 
in as two lines. This option reformats the data so it can be compared with data on 
single lines from this program or from the other Metadata Website. Only the left 
panel is able to adjust the data from this website to allow comparing to other 
sources.

Synchronize Scrolling Panels
This option links the two panels. Scrolling in one panel causes the other panel to 
scroll so that the line numbers remain linked together. This is particularly useful if 
you have used the button Line Up. This feature automatically turns off when you 
are processing the Line Up or Delete Duplicates feature, then turns back on when 
finished.

Analysis Buttons

Line Up
The Line Up button attempts to line up Exif and Makers Notes tag names in side 
by side rows in the two panels. It is a good idea to name your makers notes tags 
the same as the website you are comparing to, to maximize the value of this 
feature. If you are comparing data from this program for two different image files 
then the tag names will already match. This feature starts by aligning exactly 
matched tag names. Then it tries to line up partially matching tags, and finally 
shows unmatched tags. Hopefully this will make visual comparisons between the 
data in two panels much easier.
NOTE: Line Up is automatically part of the Delete Duplicates button.

Show Selected
Often it will be useful to select only a few rows of data that you wish to compare. 
This is done by clicking in the gutter next to the desired line to select it. This 
button will remove all other data in both panels so you can easily make your 
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comparison. Note that Panel Options > Restore .. can restore the removed rows if 
needed.

Remove Selected
This option is the opposite of Show Selected. It removes all hi-lited rows of data. 
Note that Panel Options > Restore .. can restore the removed rows if needed.

Clip Selected
This option copies all selected rows to the clipboard so you can paste them 
wherever needed. Selected rows from both panels are included.

Delete Duplicates
This option first executes the Line Up feature. Then it removes any rows that have 
identical tag names AND identical values. Hopefully this will allow you to 
rapidly identify the tags that are different and thus worth inspecting. Note that 
Panel Options > Restore .. can restore the removed rows if needed.

Forensic use of this program
This program may have limited forensic value. Exif data may be helpful in 
determining if an image has been edited. (This program does not change or re-
save image files in any way, except File > Save As.) Many editing programs 
update the “Software” tag. The loss of Exif data would also demonstrate 
tampering. That does not represent a comprehensive method of determining if 
changes have been made, however.

When using this program for forensic purposes, be sure to record MD5 hashes for 
all test photos before using this program and then confirm those MD5 hashes are 
identical after using this program. I have tried to insure that no damage to your 
test files will occur, but it is best for you to confirm this as part of your test 
protocol.

Makers Notes may include the camera serial number and/or the lens serial 
number. This might be useful in proving which camera took a photo. In my 
limited testing so far, there are some problems:

My Panasonic camera reports a camera serial number that bears no resemblance 
to the number engraved on the exterior of the camera (the program now translates 
that serial number data, but it still doesn’t match the serial number engraved on 
the camera). It also reports the serial number of Panasonic lenses, but the internal 
serial number does not match the number engraved on the lens. In contrast, it 
reports the serial number of an Olympus lens correctly. If you wish to connect a 
particular camera or lens to a photo, be sure to do some basic checking such as 
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contacting the manufacturer about whether the reported serial numbers are unique 
and whether there is a connection between the internal and external serial 
numbers. Alternately, obtain additional sample cameras or lenses and take sample 
photos to document that the numbers are unique. Take sample photos with the 
subject camera and confirm that it reports the same as the suspect photos. The 
following websites offer downloadable sample files for a variety of cameras that 
may serve as test controls:

http://www.dpreview.com/galleries/reviewsamples/albums
http://owl.phy.queensu.ca/~phil/exiftool/sample_images.html

I also found that Googling for the camera make and model with “Exif” might 
yield sample photos.

You can also use the Extras Menu to obtain Exif and Makers Notes translations 
from two other fairly comprehensive programs. This may provide additional 
assistance to a forensic examination. The default command lines for those 
programs do not damage or change files in any way. Be cautious about changing 
those defaults since both programs have very powerful features for changing Exif 
data in files.

You should not rely on the Makers Notes translation provided by this program 
until you have confirmed them with sample photos taken with the subject camera. 
This program may be a useful tool, but offers no guarantees. Your testimony 
should be based on your confirmation of the results provided by this program.

Version Notes:
Version No. Changes
1.0.0.1 Original version compiled in Delphi 7 using dExif to read Exif data.
1.0.0.2 Interim version compiled with Delphi Explorer 2006 using both dExif 

and CCR-Exif to read Exif data and CCR-Exif to read Makers Notes.
2.0.0.0 Compiled with Delphi XE using only CCR-Exif. dExif no longer 

worked properly and was removed.
Added menu with many options for configuring the display.
Added left/right panel display and the option to configure favorites in 
the left panel, plus the option to select which panel is reported via the 
DDE interface.
Added the ability to read Exif data from a .PSD file.
Added the Extras Menu.
Modified the MakerNotes.INI. The translation “Nikon ISO Speed Use” 
was changed to “ISO Speed” to agree with Canon and to help the 
Favorites feature capture the information. 
Replaced ISOSpeed Ratings” and “ISO:” Exif tags. This program 
standardizes with “ISO Speed”.
Added CRC and MD5 hashing options.
Added ExifTools.exe and Exiv2.exe to the DDE output options.

http://owl.phy.queensu.ca/~phil/exiftool/sample_images.html
http://www.dpreview.com/galleries/reviewsamples/albums
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Ver. 2.0.0.1 Modified how it formats baby and pet ages in Panasonic Maker Notes
Completed Panasonic Maker Notes. Not all tags were identified, but 
many were identified and many were expanded for the Panasonic DMC-
G1.
Do Not Show Makers Notes and Show only Makers Notes  are now 
mutually exclusive.
Implemented new CCR-Exif version with better error handling for 
corrupted Makers Notes.
NikonType2 EXIF data now yields the ISO speed from the raw data, if it 
wasn't stored in the normal EXIF tag.
Implemented improved CCR-Exif flash detail reporting and removed 
flash reporting based on raw Exif translation.
Configuration > Configure Favorite Tags for Left Panel > Save Tag 
Configuration now handles automatic stripping of current values 
delimited by = or :.
Added the ability to modify the .INI file to set a custom caption for the 
program.

Ver. 2.0.0.2 Fixed some bugs that caused the program to return no Exif data if it was 
unable to read the original or modified dates. Now it returns blank dates 
along with the remaining Exif data.
Compiled with Delphi XE2.
Added new DDE command: {NOEXIF}
Added ability to view Exif data for .JPEG files and .TIFF, assuming 
they are in standard .JPG or .TIF format. 
The font size can now be changed up to size 18 instead of 14 via 
Ctrl+Plus and Ctrl+Minus.
The font size is now stored and restored from the .INI file.
The file name being analyzed now displays in the status bar.
Added Edit > Find on the menu bar.
Modified colors to minimize affect of Windows Themes.
Modified GPS coordinate translation to include a format that is 
compatible with Google Maps and Bing Maps.

Ver. 2.0.0.3 Modified Extras menu with two choices for raw data display.
   Show CCR &Raw Exif with Favorites
   Show CCR Raw Exif with full Exif

Ver. 2.0.0.4
02/07/2017

Improved handling of {NOEXIF} DDE command.

Added Extras > Display incoming DDE command
Replaced the main menu with the TMS advanced menu and set the font 
size to 12 for greater readability.

Ver. 2.0.0.6 Added ability to include a tag in the Favorites left panel. It must start 
with a minimum of 3 === signs.
The number of Favorites tags was previously limited to 75. It is now 
250. Any blank tag will stop reading the list.

Ver 3.0.0.1 Added Extras > Popup Comparison Form to allow comparing values 
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May 2020 from two files.
Added ability to display raw Offset Time, Offset Time Original, Offset 
Time Digitized for cameras that record this. (G9 did so, GH3 did not.) It 
displays with Extras > Show CCR Raw Exif with Favorites
Added ability to display a bunch of extra EXIF data tags using 
CCR_EXif.
Added ability to display additional GPS data using ImageEn.
The image of a file is now displayed via ImagEn so that correct EXIF 
values for Max Aperture can be obtained. This also allows displaying an 
image of .PSD and .TIF files.
Tag names in the .INI file for displaying Favorities now are compared in 
a case insensitive fashion so different camera .INI files can have slight 
differences in their .INI files while still displaying the information.
Updated the About form to provide correct data about available memory 
and screens.
Fixed bug that caused a pasted in OffSet Time = +00:00
OffSet Time Original = +00:00
OffSet Time Digitized = +00:00 to be saved in Favorites as +00: instead 
of just =. This prevented Favorites from displaying these Offset Times.
Added the ability to display EXIF Sub Sec Time, Sub Sec Time 
Original, and Sub Sec Time Digitized.
Added File > Save As to save only .JPG files in low resolution while 
retaining metadata. It also shrinks the file name back to the original 
camera file name with no spaces since one website requires it.
Added Extras > Launch Metadata Website. Actually two website 
options.
Changed constraints so program can shrink more and so research display 
of file count isn't cut off by a too short form.
Add Extras > Research option.
Added Configuration > Panel Viewing Options > Use ImageEn for 
EXIF - no Makers Notes option. It allows Photorenamer to take 
advantage of Favorites to display ImageEn data. As much as possible 
the captions for each tag match those from CCR-Exif to make 
comparison easy with the popup form.
Modified the option to use ExifTools and Exiv2. They now clear the 
prior contents from the left panel before displaying their own content.
Fixed bug: Show Only Hash  now actually shows the selected hash 
values plus the file info.
Added check box to show the image. Default is false.
Added ability to show User Ratings via ImageEn or CCR-Exif.
Added ability to read the Body Serial Number via Exif or ImageEn 
XMP for both ImageEn and CCR-Exif.
Added Help > View Help File
Added ability to display Image Ratio in addition to Image Size.


