ImageEn for Delphi and C++ Builder ImageEn for Delphi and C++ Builder
ImageEn Forum
Profile    Join    Active Topics    Forum FAQ    Search this forumSearch
 All Forums
 ImageEn Library for Delphi, C++ and .Net
 ImageEn and IEvolution Support Forum
 border color not updating

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Size 
UserName:
Password:
Mode 
Format  BoldItalicizedUnderline Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailBrowse for an image to attach to your post Browse for a zip to attach to your post Insert CodeInsert QuoteInsert List
   
Message 

 

Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Black Eye [B)]
Frown [:(] Shocked [:0] Angry [:(!] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
Check here to subscribe to this topic.
   

T O P I C    R E V I E W
pierrotsc Posted - Dec 26 2018 : 09:55:24
In my code or in the layer demo, the bordercolor does not update when you apply it or increase its size
UpDownBorderWidth.Position := TrackBarLayerBorderWidth.Position;
ImageEnView.CurrentLayer.BorderWidth := TrackBarLayerBorderWidth.Position;
ImageEnView.Update();

So, i enable the bordercolor, but nothing shows. i increase its size, nothing shows. then i move the later or rotate it and suddenly it shows.

Advice ?
Thanks
12   L A T E S T    R E P L I E S    (Newest First)
xequte Posted - Jan 09 2019 : 17:37:58
Hi

It is only a layer option, so the image is not affected in any way (just drawn over it). In fact if you save to any format other than ImageEn's native IEN format, the border will be lost.


Nigel
Xequte Software
www.imageen.com
MarcoG Posted - Jan 09 2019 : 09:40:20
Hi Nigel, what's rendering the borders going to do for the images? Sorry for the newbie question.
pierrotsc Posted - Jan 09 2019 : 08:41:32
awesome..thank you
xequte Posted - Jan 08 2019 : 21:10:15
FYI, in 8.3.0, it will always render the borders.

Nigel
Xequte Software
www.imageen.com
xequte Posted - Jan 03 2019 : 22:11:30
Yes, I'll see if we can devise are more standard way once we are back in the office.

Nigel
Xequte Software
www.imageen.com
pierrotsc Posted - Jan 02 2019 : 14:14:12
Nice, i will try to add some code i guess to move the layer back and forth a pixel to have the border appear
xequte Posted - Jan 02 2019 : 13:51:18
Hi

Yes, any action that puts it into "layer mode" enables the layer properties. Even settings its PosX to a non-zero value should be sufficient.

Nigel
Xequte Software
www.imageen.com
pierrotsc Posted - Dec 30 2018 : 14:10:42
Well, not really. if you add a border to a background, it does not show but if after that you rotate the background layer or just move it after you unlock it, the border shows up.
xequte Posted - Dec 28 2018 : 14:28:02
Sorry, Bill is correct. Borders aren't valid for the background layer unless they are offset (i.e. treated like a layer).

I'll improve the documentation.

Nigel
Xequte Software
www.imageen.com
w2m Posted - Dec 28 2018 : 08:57:23
Add a layer and then it will work. You can not change the Background layer border color or width.

Bill Miller
Adirondack Software & Graphics
Email: w2m@hughes.net
EBook: http://www.imageen.com/ebook/
Custom Commercial ImageEn Development
pierrotsc Posted - Dec 28 2018 : 08:33:01
Nigel, i am using the latest imageen, windows 10 and berlin. Look at the screenshot. you can see that i have a red border with a big size and nothing is showing. my code acts the same and I also use Bill's brushtool demo. Bill says it works with his demo but not on my computer. Not sure if it is a video driver issue. when i ove the layer, the border appears and then i can decresae its size or increase.

xequte Posted - Dec 26 2018 : 21:19:28
Hi

I cannot reproduce that. Are you saying it happens on on our compiled layers demo too:

https://www.imageen.com/demos/

What version of Delphi are you on? What type of layer is it?




Nigel
Xequte Software
www.imageen.com