ImageEn for Delphi and C++ Builder ImageEn for Delphi and C++ Builder
ImageEn Forum
Profile    Join    Active Topics    Forum FAQ    Search this forumSearch
 All Forums
 ImageEn Library for Delphi, C++ and .Net
 ImageEn and IEvolution Support Forum
 Connect to camera but don't show image

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Size 
UserName:
Password:
Mode 
Format  BoldItalicizedUnderline Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailBrowse for an image to attach to your post Browse for a zip to attach to your post Insert CodeInsert QuoteInsert List
   
Message 

 

Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Black Eye [B)]
Frown [:(] Shocked [:0] Angry [:(!] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
Check here to subscribe to this topic.
   

T O P I C    R E V I E W
Xavi Posted - Jan 13 2020 : 04:50:05
Hello

Finally I can compile with no errors (thanks Nigel for your coments).
Now I'm checking all options are working correc.
I have some problems connecting cameras.

I checked on 3 diferent pc with different cameras:
HP 2.0MP High Definition Webcam
ASUS USB2.0 WebCam
Logitech C922 Pro Stream Webcam

Problem come with Logitech camera.
Apparently program connects but no image is shown and I can't select any area to capture.
I triyed demo "DirectShow Frame Capture" (DShowCap.exe) and this works fine.

there may be some connection option, on or off, to produce this problem?

Thanks in advance for any tip

Xavi
2   L A T E S T    R E P L I E S    (Newest First)
Xavi Posted - Jan 17 2020 : 03:18:17
Hi Nigel

I checked other demos and work fine.

Client has 3 pc's with the same camera and my program fail in 2 pc's and it works in the third.
As a curiosity on this 2 pc the program worked first two days.

If my program or demos have camera activate then the original camera program shows message "camera is locked by other program".
If original camera program is on, demos don't activate and my program probably don't as never show video capture.

Can I check for any error code done on activation?
I think the problem is produced while activation.

Thanks for any tip

Best regards

Xavi
xequte Posted - Jan 13 2020 : 15:33:32
Hi Xavi

So it works correctly in "DirectShow Frame Capture" demo. Which demos doesn't it work?

Nigel
Xequte Software
www.imageen.com