ImageEn for Delphi and C++ Builder ImageEn for Delphi and C++ Builder

 

ImageEn Forum
Profile    Join    Active Topics    Forum FAQ    Search this forumSearch
Forum membership is Free!  Click Join to sign-up
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 ImageEn Library for Delphi, C++ and .Net
 ImageEn and IEvolution Support Forum
 Problem with cursor by Layer
 New Topic  Reply to Topic
Author Previous Topic Topic Next Topic  

klausdoege

Germany
387 Posts

Posted - Mar 13 2023 :  05:15:57  Show Profile  Reply
Hello,
ich have a problem with cursor on the corner by the layers.
The display of the cursor at layers is different than at selection.
There is an unusual cursor at the layer corners see pictures.
What can i do ?





Klaus
DigiFoto
www.klausdoege.de

xequte

38060 Posts

Posted - Mar 14 2023 :  23:30:16  Show Profile  Reply
Hi Klaus

I'm not able to reproduce that.

Is this in v12.0.0? What version of Delphi are you using? Does it occur in our demos too?


Nigel
Xequte Software
www.imageen.com
Go to Top of Page

klausdoege

Germany
387 Posts

Posted - Mar 16 2023 :  04:34:29  Show Profile  Reply
Hi Nigel,
it's v11.4.5
Your Demos are OK.
But i have not a idea what change the cursor ?

Klaus
DigiFoto
www.klausdoege.de
Go to Top of Page

klausdoege

Germany
387 Posts

Posted - Mar 16 2023 :  11:07:03  Show Profile  Reply
Hi Nigel,
when i set AutoCursors := false then it's OK.
But we see only a Hand :-)
Any idea, where the wrong cursor could come from?

Klaus
DigiFoto
www.klausdoege.de
Go to Top of Page

xequte

38060 Posts

Posted - Mar 16 2023 :  22:58:15  Show Profile  Reply
Hi Klaus

Is this with our pre-compiled demos, or are you compiling the demo yourself?

ImageEn's built-in cursors are loaded from a resource. Can you check the ImageEn DCU folder you are using contains imres.res dated at least 19 Nov 2022 (file size: 54.8 KB)


Nigel
Xequte Software
www.imageen.com
Go to Top of Page

klausdoege

Germany
387 Posts

Posted - Mar 17 2023 :  02:53:48  Show Profile  Reply
Hi Nigel,
with compiled demo by myself it's all OK.
Only my program "DigiFoto" has this problem since about 3 month ?
Yes imres.res it's from 19 Nov 2022 (filesiize 55kb)
in which unit is the cursor for moving and resizing set?
Maybe I can find something there




Klaus
DigiFoto
www.klausdoege.de
Go to Top of Page

xequte

38060 Posts

Posted - Mar 17 2023 :  16:44:46  Show Profile  Reply
Hi Klaus

See SetTempCursor() in imageenview.pas

Nigel
Xequte Software
www.imageen.com
Go to Top of Page

klausdoege

Germany
387 Posts

Posted - Mar 23 2023 :  04:53:48  Show Profile  Reply
Hi Nigel,
It was my fault.
I included a own resource with cursors.
There must have been something wrong.
After changing it works again.

Klaus
DigiFoto
www.klausdoege.de
Go to Top of Page

xequte

38060 Posts

Posted - Mar 24 2023 :  20:04:56  Show Profile  Reply
Hi Klaus

Thanks for the update.

Nigel
Xequte Software
www.imageen.com
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
Jump To: