ImageEn for Delphi and C++ Builder ImageEn for Delphi and C++ Builder
ImageEn Forum
Profile    Join    Active Topics    Forum FAQ    Search this forumSearch
Forum membership is Free!  Click Join to sign-up
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 ImageEn Library for Delphi, C++ and .Net
 ImageEn and IEvolution Support Forum
 Issue with MEMO object
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

graph_man

240 Posts

Posted - Feb 02 2020 :  06:46:28  Show Profile  Reply
When you select text with a mouse click and drag, the last character is not highlighted. It can be highlighted only by double-clicking on the word.

Tested on 8.7.5 and 8.7.6

xequte

5607 Posts

Posted - Feb 02 2020 :  19:23:54  Show Profile  Reply
OK, we'll look into this when we next update TImageEnVect.

Nigel
Xequte Software
www.imageen.com
Go to Top of Page

graph_man

240 Posts

Posted - Apr 12 2020 :  08:46:49  Show Profile  Reply
Was this problem fixed in the latest version?
Go to Top of Page

xequte

5607 Posts

Posted - Apr 13 2020 :  02:11:03  Show Profile  Reply
Hi

I'm afraid there were not any updates to TImageEnVect in this release. Also, I cannot reproduce the issue. What are the steps that I need to take?



Nigel
Xequte Software
www.imageen.com
Go to Top of Page

graph_man

240 Posts

Posted - Apr 13 2020 :  06:29:53  Show Profile  Reply
See my first message:
When you select text with a mouse click and drag, the last character is not highlighted. It can be highlighted only by double-clicking on the word.
Go to Top of Page

graph_man

240 Posts

Posted - Apr 13 2020 :  07:12:37  Show Profile  Reply
Click on memo to select a text.
Place cursor to first position of last string.
Click, hold and move mouse to right to select all symbols in this string.
The last character is not selected in this case.
It is selected only if you move the mouse much lower and to the right.
Go to Top of Page

xequte

5607 Posts

Posted - Apr 15 2020 :  17:30:25  Show Profile  Reply
Hi

I'm not seeing that. What version of Delphi are you using?



Nigel
Xequte Software
www.imageen.com
Go to Top of Page

graph_man

240 Posts

Posted - Apr 15 2020 :  17:40:27  Show Profile  Reply
C++ Builder 2010
Go to Top of Page

graph_man

240 Posts

Posted - Apr 15 2020 :  17:43:20  Show Profile  Reply
try to select all characters in a line starting from the first
Go to Top of Page

xequte

5607 Posts

Posted - Apr 15 2020 :  20:51:17  Show Profile  Reply
Please try this exe compilied in IE 9.0.0 32bit:

www.imageen.com/temp/VectActions.zip

Nigel
Xequte Software
www.imageen.com
Go to Top of Page

graph_man

240 Posts

Posted - Apr 16 2020 :  15:52:58  Show Profile  Reply
How to change the font size here?
Go to Top of Page

xequte

5607 Posts

Posted - Apr 16 2020 :  18:09:14  Show Profile  Reply
There is no option for that in that demo. Does font size affect this issue?

Nigel
Xequte Software
www.imageen.com
Go to Top of Page

AndyKolb

Switzerland
2 Posts

Posted - Oct 14 2020 :  08:04:15  Show Profile  Reply
I confirm the problem. It's very annoying !
To reproduce input least 2 lines.
Then align to "center" in example.
Then try to select with the mouse backwards.
The last is skipped always. In the most cases cou' can not select the last char.
Only shift with cursor keys works always.

This Problem is urgent o solve because my customers are not so happy with this annoying bug.
Go to Top of Page

xequte

5607 Posts

Posted - Oct 14 2020 :  23:03:14  Show Profile  Reply
Hi

So this is a memo object, correct? What version of Delphi and ImageEn are you using?

Unfortunately I cannot reproduce the issue here.




Nigel
Xequte Software
www.imageen.com

Go to Top of Page

AndyKolb

Switzerland
2 Posts

Posted - Oct 15 2020 :  02:19:28  Show Profile  Reply
Hi

I use the newest version of imageen v9.2.0.
Please do not forget, today's devices are often ultra hd.
We work with 4k images, by that I mean with 3840x1200 pixels and even more.
So it is important to test ride with the highest standards !
Here is the bug with your own demo software:

Key points:
4k picture in the background
maybe 2 or 3 other memos with different Fonts(Memo Multi Font does not work in the demo)
Font size 48
x64 compilation

This should work to reproduce the problem.
On the attached picture you can see that I tried to select the characters "ture" backwards, but only "tur" is marked and the last "e" is not considered.


Go to Top of Page

xequte

5607 Posts

Posted - Oct 18 2020 :  22:49:25  Show Profile  Reply
Thanks for your explanation, Andy,

I have a fix for this. You can email me for updated source code, or wait for v9.2.1 over the next couple of weeks.



Nigel
Xequte Software
www.imageen.com
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To: