ImageEn for Delphi and C++ Builder ImageEn for Delphi and C++ Builder

 

ImageEn Forum
Profile    Join    Active Topics    Forum FAQ    Search this forumSearch
Forum membership is Free!  Click Join to sign-up
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 ImageEn Library for Delphi, C++ and .Net
 ImageEn and IEvolution Support Forum
 Installing ImageEn 11.4.5 lite
 New Topic  Reply to Topic
Author Previous Topic Topic Next Topic  

Aquil8

Italy
6 Posts

Posted - Jan 27 2023 :  12:19:28  Show Profile  Reply
Hi all,

recently I've purchased ImageEn v.11.4.5 lite. I install it but when I load Delphi 10.2 Tokyo I get this error mesage: "Can't load package c:\ProgramData\ImageEn\Delphi10.2Tokyo\DPKIECTRL25.BPL. Cannot find the specified module".

In "Install Packages" window I see "ImageEn Controls" and "ImageEn DB Controls" without flag. If I flag one of them, I get the same error message again.

I bought the lite version of ImageEn 11.4.5. Previously I used ImageEn v.10 trial without problems.



Could you help me please?

Maurizio Losso

xequte

38163 Posts

Posted - Jan 27 2023 :  13:06:24  Show Profile  Reply
Hi Maurizio

Sorry, did you not receive my email from the other day? I have resent it.


I would try removing all traces of the demo and then installing again:

Search your system for any PKIE*.* and DPKIE*.* files and remove them (it might help to review the library paths under Tools > Options, Library). Then reinstall ImageEn.

Please also see:

https://www.imageen.com/support/faq.html#1

Let me know if that resolves it.


Also, check that the paths of the ImageEn BPL and DCU files have been correctly added to the Delphi Options.


Nigel
Xequte Software
www.imageen.com
Go to Top of Page

Aquil8

Italy
6 Posts

Posted - Jan 27 2023 :  14:22:40  Show Profile  Reply
Hi Nigel,
thank you for the reply.

I have not received your mail, probably because in Italy we are having problems with some mail providers. Today I sent you an email from another provider explaining this.

I've already read in the forum to search for all PKIE*.* and DPKIE*.* files and delete them.
And also library paths are correct.

I have done these operations many times without any positive result.

Now I also deleted all the files called ImageEn*.*. But the problem is not solved....


At the moment the only version that works is the demo version....

Maurizio Losso
Go to Top of Page

xequte

38163 Posts

Posted - Jan 27 2023 :  21:55:18  Show Profile  Reply
Hi Maurizio

I have not received an email from you today. Did you receive the one I just sent you now?

Are you installing the registered version to the same location that you had the trial?

If not, you could try copying the files from your registered folder, to the same location that the trial ones exists (BPL, DCU files, etc)

Nigel
Xequte Software
www.imageen.com
Go to Top of Page

Aquil8

Italy
6 Posts

Posted - Jan 28 2023 :  03:04:52  Show Profile  Reply
Hi Nigel,
unfortunately the "inwind" email account is still down. Did you also send an email to my "gmail" account?
I tried to install ImageEn both in the same directory of the Trial version and in a different directory and then copy all the files in the folder of the trial version, without any success.

It seems that the .bpl files are not compatible with the Delphi 10.2 version.
In particular I have version 10.2.2 of Delphi.....
Go to Top of Page

xequte

38163 Posts

Posted - Jan 28 2023 :  14:13:32  Show Profile  Reply
Hi

Yes, Embarcadero had a weird issue with the binary compatibility of Delphi 10.2.2. There was patch issued to fix it, IIRC:

https://www.ideasawakened.com/post/about-binary-compatibility-on-new-versions-of-delphi

I've just sent another version to your Gmail account. If you have issues with it, please recompile the packages, as outlined at:

https://www.imageen.com/help/Installation.html


Nigel
Xequte Software
www.imageen.com
Go to Top of Page

Aquil8

Italy
6 Posts

Posted - Jan 29 2023 :  06:59:23  Show Profile  Reply
Hi Nigel,
I try to install new version of ImageEn, but it doesn't works in Tokyo 10.2.2. I've trobule on installing the patch to Delphi 10.2.2. So I decided to install Sydney version. Here it is all ok!!

I hope I don't need to use ImageEn in old projects that only run on Delphi 10.2.2. However at the moment I solved by installing the Sydney version of Delphi.

Thank you very much for all.
Go to Top of Page

xequte

38163 Posts

Posted - Jan 29 2023 :  13:25:33  Show Profile  Reply
Hi

If you do need 10.2.2 support and can't install the Embarcadero patch, then you should recompile the packages:

https://www.imageen.com/help/Installation.html

Nigel
Xequte Software
www.imageen.com
Go to Top of Page

Aquil8

Italy
6 Posts

Posted - Jan 29 2023 :  13:42:34  Show Profile  Reply
Hi,
I tried to compile the dpks. But even this did not give positive results.
Go to Top of Page

xequte

38163 Posts

Posted - Jan 29 2023 :  16:49:57  Show Profile  Reply
You will probably find it easiest if you move the DPKIECTRL25.DPK and PKIECTRL25.DPK files to the same folder as the ImageEn pas/source files. Then open and compile them there (make sure you have deleted all DPKIECTRL25.BPL and PKIECTRL25.BPL files first).

Nigel
Xequte Software
www.imageen.com
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
Jump To: